欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU-2602 Bone Collector(01背包)

程序员文章站 2022-07-01 10:42:29
...

HDU-2602 Bone Collector(01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

HDU-2602 Bone Collector(01背包)

 

 

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

 

Sample Input

 

15 101 2 3 4 55 4 3 2 1

 

Sample Output

 

14

 

 

Author

Teddy

 

 

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1203 2159 2955 1171 2191 

 

01背包(ZeroOnePack): 有N件物品和一个容量为V的背包。(每种物品均只有一件)第i件物品的费用是c[i],价值是w[i]。求解将哪些物品装入背包可使价值总和最大。

01背包就是取还是不取的问题

 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define MAXN 1010
int dp[MAXN][MAXN];  //dp[i][j]表示i个物品,体积为j时的最大价值
int value[MAXN],w[MAXN];
int main()
{
   int t;
   int n,v;
   int i,j;
   scanf("%d",&t);
   while(t--)
   {
     memset(dp,0,sizeof(dp));
     scanf("%d%d",&n,&v);
     for(i=1;i<=n;i++)
     scanf("%d",&value[i]);
     for(i=1;i<=n;i++)
     scanf("%d",&w[i]);
     for(i=1;i<=n;i++)
     for(j=v;j>=0;j--)          //体积是从大到小变化的, for(j=0;j<=v;j++) 也是可以的
     {                          //也就是说这里是有两种情况讨论的
     
         if(j>=w[i])
         dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+value[i]);//不要当前物品是i-1来的, 
         //要也是i-1来的              
         else
         dp[i][j]=dp[i-1][j];   //一开始是没这个物品的,装不下的话也只能这样
     }
     cout<<dp[n][v]<<endl;
   }
    return 0;
}