欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Bone Collector HDU 2602 DP 01 背包

程序员文章站 2022-07-01 10:38:43
...

Bone Collector

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 76372    Accepted Submission(s): 31644

 

 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Bone Collector HDU 2602 DP 01 背包

 

 

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

 

Sample Input

 

1 5 10 1 2 3 4 5 5 4 3 2 1

 

 

Sample Output

 

14

 

 

Author

Teddy

 

 

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

01背包啥都没改,不解释了。。。。

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+7;

int n, t, v,  dp[maxn], vaule[maxn], volume[maxn];

int main()
{
    scanf("%d", &t);
    while(t--) {
     scanf("%d%d", &n, &v);
     for(int i = 0; i < n; i++) scanf("%d", &vaule[i]);
     for(int i = 0; i < n; i++) scanf("%d", &volume[i]);
     memset(dp, 0, sizeof(dp));
     int maxl = 0;
     for(int i = 0; i < n; i++)
        for(int j = v; j >= volume[i]; j--) {
            dp[j] = max(dp[j], (dp[j - volume[i]] + vaule[i]));
            maxl = max(dp[j], maxl);
        }
    printf("%d\n", maxl);
    }
    return 0;
}