欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU2602 Bone Collector(01背包)

程序员文章站 2022-07-01 10:42:17
...
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDU2602 Bone Collector(01背包)

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

14
 

Author
Teddy

代码:

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn=1005;
int w[maxn],v[maxn],dp[maxn];

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        int n,V;
        scanf("%d%d",&n,&V);
        for(int i=1;i<=n;i++) scanf("%d",&w[i]);
        for(int i=1;i<=n;i++) scanf("%d",&v[i]);
        for(int i=0;i<=V;i++) dp[i]=0;
        for(int i=1;i<=n;i++)
            for(int j=V;j>=v[i];j--)
                dp[j]=max(dp[j],dp[j-v[i]]+w[i]);
        printf("%d\n",dp[V]);
    }
    return 0;
}

上一篇: 结巴分词

下一篇: RTSP 鉴权认证