欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDUOJ 2602 Bone Collector

程序员文章站 2022-06-04 15:45:22
...

HDUOJ 2602 Bone Collector

题目链接

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDUOJ 2602 Bone Collector

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

01背包裸题~
我们用 dp[j]dp[j] 表示容量为 jj 时获得的最大价值,则有状态转移方程:
dp[j]=max(dp[j],dp[jw[i]]+v[i]),i[0,n)dp[j]=max(dp[j],dp[j-w[i]]+v[i]),i\in[0,n)
AC代码如下:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int main(){
    int t,n,m;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        int w[n],v[n],dp[m+1]={0};
        for(int i=0;i<n;i++) scanf("%d",&v[i]);
        for(int i=0;i<n;i++) scanf("%d",&w[i]);
        for(int i=0;i<n;i++){
            for(int j=m;j>=w[i];j--){
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
            }
        }
        printf("%d\n",dp[m]);
    }
}
相关标签: 背包问题 HDUOJ