欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU1698 Just a Hook (简单的区间更新线段树)

程序员文章站 2022-06-16 08:45:58
...

Just a Hook

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 50 Accepted Submission(s): 35
 
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

HDU1698 Just a Hook (简单的区间更新线段树)


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 
Output

            For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 
Sample Input
1
10
2
1 5 2
5 9 3
 
Sample Output
Case 1: The total value of the hook is 24.
 
 
Source
2008 “Sunline Cup” National Invitational Contest
 
emmm。。都在注释里
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn = 200010;
struct Node {
    int left, right, color;
}tree[maxn << 2];
//建树
void build(int node, int left, int right) {
    tree[node].left = left;
    tree[node].right = right;
    tree[node].color = 1;
    if (right == left)
        return;
    int mid = (left + right) >> 1;
    build(node << 1, left, mid);
    build(node << 1 | 1, mid + 1, right);
}

void insert(int node, int left, int right, int val) {
        //如果值相等,就不用更新了
    if (tree[node].color == val)
        return;
        //如果正好是区间,则更新
    if (tree[node].left == left && tree[node].right == right) {
        tree[node].color = val;
        return;
    }
        //如果区间本来只有一种颜色,插入一个新颜色就不只有一种颜色了
    if (tree[node].color != -1) {
        tree[node << 1].color = tree[node << 1 | 1].color = tree[node].color;
        tree[node].color = -1;
    }
    
    int mid = (tree[node].left + tree[node].right) >> 1;
    if (left > mid) {
        insert(node << 1 | 1, left, right, val);
    } else if (right <= mid) {
        insert(node << 1, left, right, val);
    } else {
        insert(node << 1, left, mid, val);
        insert(node << 1 | 1, mid + 1, right, val);
    }
}

int find(int node) {
    if (tree[node].color != -1) {
        return (tree[node].right - tree[node].left + 1) * tree[node].color;
    }
    
    return find(node << 1) + find(node << 1 | 1);
}
int main() {
        //freopen("in.txt", "r", stdin);
    int t, a, b, c;;
    scanf("%d", &t);
    for (int i = 1; i <= t; ++i) {
        int n, k;
        scanf("%d%d", &n, &k);
        build(1, 1, n);
        for (int j = 0; j < k; ++j) {
            scanf("%d%d%d", &a, &b, &c);
            insert(1, a, b, c);
        }
        
        printf("Case %d: The total value of the hook is %d.\n", i, find(1));
    }
}