欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU1698 Just a Hook【线段树基础:区间修改+区间查询】

程序员文章站 2022-06-16 08:42:02
...

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 44248    Accepted Submission(s): 21158


 

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

HDU1698 Just a Hook【线段树基础:区间修改+区间查询】

Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:


For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.


Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

 Source

2008 “Sunline Cup” National Invitational Contest

问题链接:HDU1698 Just a Hook

题解:线段树基础:区间修改+区间查询

AC的C语言代码:

#include<stdio.h>
#include<string.h>
#define N 100005
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1
int sum[N<<2],add[N<<2],a[N];

//更新函数
void PushUp(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
} 

//建树
void Build(int l,int r,int rt)
{
	if(l==r){
		sum[rt]=a[l];
		return;
	}
	int m=(l+r)>>1;
	Build(ls);
	Build(rs);
	PushUp(rt);//更新本结点 
}

//下推标记函数
void PushDown(int rt,int ln,int rn)//ln和rn分别表示rt的左右子树的数量 
{
	if(add[rt]){
		//下推标记 
	    add[rt<<1]=add[rt<<1|1]=add[rt];
		//修改子结点的区间信息sum,使之与对应的add相对应 
		sum[rt<<1]=add[rt]*ln;
		sum[rt<<1|1]=add[rt]*rn;
		//清除本结点的标记 
		add[rt]=0; 
	}
}
//区间修改
void Update(int L,int R,int C,int l,int r,int rt)
{
	if(L<=l&&r<=R){
		sum[rt]=C*(r-l+1);//更新数字和,向上保持正确 
		add[rt]=C;//增加标记,表示本区间的sum正确 
		return;
	}
	int m=(l+r)>>1;
	PushDown(rt,m-l+1,r-m);//下推标记 
	if(L<=m)
	  Update(L,R,C,ls);
	if(R>m)
	  Update(L,R,C,rs);
	PushUp(rt); 
} 

//区间查询
int Query(int L,int R,int l,int r,int rt)
{
	if(L<=l&&r<=R)
	  return sum[rt];
	int m=(l+r)>>1;
	//下推标记,否则sum可能不正确
	PushDown(rt,m-l+1,r-m);
	int ans=0;
	if(L<=m)
	  ans+=Query(L,R,ls);
	if(R>m)
	  ans+=Query(L,R,rs);
	return ans;
}

int main()
{
	int n,q,i,j,x,y,z,t;
	scanf("%d",&t);
	for(i=1;i<=t;i++){
		memset(add,0,sizeof(add));//初始化标记数组 
		scanf("%d%d",&n,&q);
		for(j=1;j<=n;j++)
		  a[j]=1;
		Build(1,n,1);
		while(q--){
			scanf("%d%d%d",&x,&y,&z);
			Update(x,y,z,1,n,1);
		}
		printf("Case %d: The total value of the hook is %d.\n",i,Query(1,n,1,n,1));	
	}
	return 0;
}