欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

A - A Knight's Journey (poj2488)(dfs经典)

程序员文章站 2022-03-31 10:05:09
...
A Knight's Journey
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27258   Accepted: 9295

Description

A - A Knight's Journey (poj2488)(dfs经典)Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

大致题意:给出一个p行q列的国际棋盘,马可以从任意一个格子开始走,问马能否不重复的走完所有的棋盘。如果可以,输出按字典序排列最小的路径。打印路径时,列用大写字母表示(A表示第一列),行用阿拉伯数字表示(从1开始),先输出列,再输出行。

分析:如果马可以不重复的走完所有的棋盘,那么它一定可以走到A1这个格子。所以我们只需从A1这个格子开始搜索,就能保证字典序是小的;除了这个条件,我们还要控制好马每次移动的方向,控制方向时保证字典序最小(即按照下图中格子的序号搜索)。控制好这两个条件,直接从A1开始深搜就行了。

A - A Knight's Journey (poj2488)(dfs经典)


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<deque>
#include<map>
using namespace std;


int p,q;
int sum;
bool g[30][30];
//int dx[8]={-1,-1,-2,-2,1,1,2,2};
//int dy[8]={-2,2,-1,1,-2,2,-1,1};
int dx[8]={-1,1,-2,2,-2,2,-1,1};
int dy[8]={-2,-2,-1,-1,1,1,2,2};
bool find1;
struct point
{
	int x,y;
	point(int xx,int yy):x(xx),y(yy){}
};
deque<point> dq; 

void dfs(int x,int y,int step)
{
	if(step==sum)
	{
		find1=true;
	}
	if(find1)
	return;
	if(x<1||x>p||y<1||y>q)
	return;
	int i;
	for(i=0;i<8;i++)
	{
		int xx=dx[i]+x;
		int yy=dy[i]+y;
		if(x<1||x>p||y<1||y>q)
		continue;
		if(g[xx][yy]==0&&!find1)
		{
			g[xx][yy]=1;
			dq.push_back(point(xx,yy));
			dfs(xx,yy,step+1);
			if(find1)
			return;
			dq.pop_back();
			g[xx][yy]=0;
		}
	}
}


int main(void)
{
	//map<pair<int,int>,string> mp;
	int t;
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		
		scanf("%d %d",&p,&q);
		//if(mp.find(make_pair(p,q))!=mp.end())
		//{
		//	printf("Scenario #%d:\n",i);
		//	cout<<mp[make_pair(p,q)]<<endl<<endl;
		//	continue;
		//}
		sum=p*q;
		memset(g,0,sizeof(g));
		find1=0;
//		int k,j;
//		for(j=1;j<=p;j++)
//		{
//			for(k=1;k<=q;k++)
//			{
//				dq.clear();
//				g[k][j]=1;
//				dq.push_back(point(k,j));
//				dfs(k,j,0);
//				g[k][j]=0;
//				if(find1)
//				break;
//			}
//			if(find1)
//			break;
//		}
		dq.clear();
		g[1][1]=1;
		dq.push_back(point(1,1));
		dfs(1,1,1);
		printf("Scenario #%d:\n",i);
		if(find1)
		{
			//string a="";
			while(dq.size())
			{
				point now=dq.front();
				dq.pop_front();
				//a+=('A'+(now.y-1));
				//a+=(now.x+'0');
				printf("%c%d",'A'+(now.y-1),now.x);
			}
			//mp.insert(make_pair(make_pair(p,q),a));
			printf("\n");
		}
		else
		{
			printf("impossible\n"); 
		}
		if(i!=t)
		printf("\n");
	}
	return 0;
}

代码:(优化了用时却多了)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<deque>
#include<map>
using namespace std;


int p,q;
int sum;
bool g[30][30];
//int dx[8]={-1,-1,-2,-2,1,1,2,2};// !!! lexicographically !!!
//int dy[8]={-2,2,-1,1,-2,2,-1,1};
int dx[8]={-1,1,-2,2,-2,2,-1,1};
int dy[8]={-2,-2,-1,-1,1,1,2,2};
bool find1;
struct point
{
	int x,y;
	point(int xx,int yy):x(xx),y(yy){}
};
deque<point> dq; 

void dfs(int x,int y,int step)
{
	if(step==sum)
	{
		find1=true;
		dq.pop_back();
	}
	if(find1)
	return;
	if(x<1||x>p||y<1||y>q)
	return;
	int i;
	for(i=0;i<8;i++)
	{
		int xx=dx[i]+x;
		int yy=dy[i]+y;
		if(x<1||x>p||y<1||y>q)
		continue;
		if(g[xx][yy]==0)
		{
			g[xx][yy]=1;
			dq.push_back(point(xx,yy));
			dfs(xx,yy,step+1);
			if(find1)
			return;
			dq.pop_back();
			g[xx][yy]=0;
		}
	}
}


int main(void)
{
	map<pair<int,int>,string> mp;
	int t;
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		
		scanf("%d %d",&p,&q);
		if(mp.find(make_pair(p,q))!=mp.end())
		{
			printf("Scenario #%d:\n",i);
			cout<<mp[make_pair(p,q)]<<endl<<endl;
			continue;
		}
		sum=p*q;
		memset(g,0,sizeof(g));
		find1=0;
		dq.clear();
		g[1][1]=1;
		dfs(1,1,0);
		dq.push_front(point(1,1));
		printf("Scenario #%d:\n",i);
		if(find1)
		{
			string a="";
			while(dq.size())
			{
				point now=dq.front();
				dq.pop_front();
				a+=('A'+(now.y-1));
				a+=(now.x+'0');
				printf("%c%d",'A'+(now.y-1),now.x);
			}
			mp.insert(make_pair(make_pair(p,q),a));
			printf("\n");
		}
		else
		{
			printf("impossible\n"); 
		}
		if(i!=t)
		printf("\n");
	}
	return 0;
}

代码:(别人的)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int path[88][88], vis[88][88], p, q, cnt;
bool flag;

int dx[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int dy[8] = {-2, -2, -1, -1, 1, 1, 2, 2};

bool judge(int x, int y)
{
    if(x >= 1 && x <= p && y >= 1 && y <= q && !vis[x][y] && !flag)
        return true;
    return false;
}

void DFS(int r, int c, int step)
{
    path[step][0] = r;
    path[step][1] = c;
    if(step == p * q)
    {
        flag = true;
        return ;
    }
    for(int i = 0; i < 8; i++)
    {
        int nx = r + dx[i];
        int ny = c + dy[i];
        if(judge(nx,ny))
        {

            vis[nx][ny] = 1;
            DFS(nx,ny,step+1);
            vis[nx][ny] = 0;
        }
    }
}

int main()
{
    int i, j, n, cas = 0;
    scanf("%d",&n);
    while(n--)
    {
        flag = 0;
        scanf("%d%d",&p,&q);
        memset(vis,0,sizeof(vis));
        vis[1][1] = 1;
        DFS(1,1,1);
        printf("Scenario #%d:\n",++cas);
        if(flag)
        {
            for(i = 1; i <= p * q; i++)
                printf("%c%d",path[i][1] - 1 + 'A',path[i][0]);
        }
        else
            printf("impossible");
        printf("\n");
        if(n != 0)
            printf("\n");
    }
    return 0;
}

相关标签: dfs deque