欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页  >  IT编程

HDU GCC(HDU 3123)解题报告

程序员文章站 2022-10-18 19:27:17
/*Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (...

/*Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2646    Accepted Submission(s): 810


Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

 

Sample Input
1
10 861017
 

Sample Output
593846
*/

[html]
#include<stdio.h> 
#include<stdlib.h> 
#include<string.h> 
char n[1010]; 
__int64 m; 
int main() 

 __int64 num,sum=0; 
 int i,T,m,k; 
 scanf("%d",&T); 
 while(T--) 
 { 
  scanf("%s%d",n,&m); 
        if(strlen(n)>=7) 
      k=m; 
  else 
           k=atoi(n); 
     num=1,sum=1; 
     for(i=1;i<=k;i++) 
  { 
          num=(num*i)%m; 
    sum=(sum+num)%m; 
  } 
     printf("%I64d\n",sum%m); 
 } 
 return 0; 

作者:xieqinghuang