欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ3278抓牛 bfs:队列+struct

程序员文章站 2022-07-15 16:10:53
...

B - 抓牛 POJ - 3278

自用
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
郭炜老师的代码,十分清晰,其中结构体的最后一句是为了便于初始化

#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
int N,K;
int MAXN = 100000;
int mk[100010];
struct step{
	int x;
	int steps;
	step(int xx,int s):x(xx),steps(s){
	}
};
queue<step> q;
int main() {
	cin>>N>>K;
	memset(mk,0,sizeof(mk));
	q.push(step(N,0));
	mk[N] = 1;
	while(!q.empty()){
		step s = q.front();
		if(s.x == K){
			cout<<s.steps<<endl;
			return 0;
		}
		else{
			if(s.x -1 >= 0&&!mk[s.x-1]){
				q.push(step(s.x-1,s.steps+1));
				mk[s.x-1] = 1;
			}
			if(s.x +1 <= MAXN&&!mk[s.x+1]){
				q.push(step(s.x+1,s.steps+1));
				mk[s.x+1] = 1;
			}
			if(s.x *2 <= MAXN&&!mk[s.x*2]){
				q.push(step(s.x*2,s.steps+1));
				mk[s.x*2] = 1;
			}
			q.pop();
		}
	}
	return 0;
}

GQ学长细心的解释:
POJ3278抓牛 bfs:队列+struct
总结:最近一个月学习的状态十分不好,不能让gqg在问我的时候那么令人失望。。。。Orz

  • 周末之前,搞定WORD**“算法很美”**
相关标签: 寒假的小尾巴