欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

[Python](PAT)1122 Hamiltonian Cycle(25 分)

程序员文章站 2022-07-15 13:37:38
...

Python写PAT甲级,答案都在这儿了

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题目大意

“Hamiltonian cycle”包含了图中所有的顶点,而且这个集合从头到尾的点之间都有边连接

如果给出的一个查询中的子集是“Hamiltonian cycle”,输出“YES”,否则输出NO。

Python实现

def main():
    line = input().split(" ")
    n, m = int(line[0]), int(line[1])
    dic = [ [0 for x in range(n)] for x in range(n)]
    for x in range(m):
        line = input().split(" ")
        a, b = int(line[0])-1, int(line[1])-1
        dic[a][b], dic[b][a] = 1, 1
    k = int(input())
    for x in range(k):
        line = input().split(" ")
        num = int(line[0])
        if line[1] != line[-1] or num < n:
            print("NO")
            continue
        else:
            line = line[1:]
            get = [int(x)-1 for x in line]
            flag = True
            if get.count(get[0]) > 2:
                print("NO")
                continue
            for i in range(len(line)-1):
                if dic[get[i]][get[i+1]] == 0:
                    flag = False
                    break
            if flag:
                print("YES")
            else:
                print("NO")

if __name__ == "__main__":
    main()