欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1011 World Cup Betting (20 分)_14行代码AC

程序员文章站 2022-07-15 13:30:55
...

立志用最少的代码做最高效的表达


PAT甲级最优题解——>传送门


With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:
T T W 39.31


没读题。。直接看输入输出就懂了 就是取每行最大值,带入公式即可。

别问我为啥不用else-if,问就是强迫症犯了
1011 World Cup Betting (20 分)_14行代码AC


#include<bits/stdc++.h>
using namespace std;
int main() {
	double a, b, c, sum = 0.65; 
	for(int i = 0; i < 3; i++) {
		double a, b, c, Max; cin >> a >> b >> c;
		if(a>b && a>c) { cout << 'W' << ' '; Max = a; } 
		if(b>a && b>c) { cout << 'T' << ' '; Max = b; } 
		if(c>a && c>b) { cout << 'L' << ' '; Max = c; } 
		sum *= Max;
	}
	printf("%.2lf\n", (sum-1)*2);
	return 0;
} 

耗时:

1011 World Cup Betting (20 分)_14行代码AC