欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

【PAT甲级】【1002】 A+B for Polynomials (25分)

程序员文章站 2022-07-15 13:25:43
...

问题描述:

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

【PAT甲级】【1002】 A+B for Polynomials (25分)

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 

问题解析:

  •  对应多项式的项数可以设定数组,每一项都可一一对应数组中的单元,最后将数组中值不为零的有效单元计数输出即可。

AC代码:

#include<iostream>
#include<string>
#include<iomanip>
using namespace std;
int main() {
	int k, n = 0, t;
	double p[1005] = { 0 }, a;
	for (int i = 0; i < 2; i++) {
		cin >> k;
		for (int j = 0; j < k; j++) {
			cin >> t >> a;
			if (p[t] == 0)n++;
			p[t] += a;
			if (p[t] == 0)n--;
		}
	}
	cout << n;
	for (int i = 1004; i >= 0; i--) {
		if (p[i] != 0)cout << " " << i << " "<<fixed<<setprecision(1)<< p[i];
	}
	return 0;
}