欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

PAT-A1039 Course List for Student【Map的使用】

程序员文章站 2022-07-15 11:03:28
...

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

先暴力算一波

#include <iostream>
#include <vector>
#include <string>
#include <map>
using namespace std;
int main(){
	vector<string> course[2501];
	int numofstu, numofcou;
	int couid,counum;
	string name;
	scanf("%d %d",&numofstu,&numofcou);
	for(int i=0;i<numofcou;i++){             //储存课程下的学生名单
		scanf("%d %d",&couid,&counum);
		while(counum--){
			cin>>name;
			course[couid].push_back(name);
		}
	}
	vector<int> res;                         //保存查询课程id
	while(numofstu--){
		cin>>name;
		res.clear();
		for(int j=1;j<=numofcou;j++){
			for(vector<string>::iterator li=course[j].begin();li!=course[j].end();li++){
				if(*li==name){
					res.push_back(j);        //遍历所有的课程找这个学生名字,找到了就把课程
                                             //id让入到res中,break掉这层循环
					break;
				}
			}
		}
		cout<<name<<" "<<res.size();        //模拟输出
		for(int a=0;a<res.size();a++){
			cout<<" "<<res[a];
		}
		cout<<endl;
		
	}
return 0;
}

 意料之内的,会报一个运行超时;PAT-A1039 Course List for Student【Map的使用】

改进一下,初步认为,造成超时的原因主要是课程很多的时候遍历所有的vector的遍历方法造成的,遍历所有的 vector暂时看来是不可避免的,那么久想办法改进一下遍历方法

之前使用的是从头到尾一串撸下去,算法的时间复杂度是O(n),快速查找的方法还有O(log n)的折半查询。但是折半查询要求数组是有序的,因此在查之前,要将数组排序,使用默认的sort

改进之后代码:

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
using namespace std;
int findName(const vector<string> namelist, string name){
	
	int left=0,right=namelist.size()-1;
	int middle;
	while(left<=right){
		middle=(left+right)/2;
		if(name<namelist[middle]){
			right=middle-1;
		}
		else if(name>namelist[middle]){
			
			left=middle+1;
		}
		else{
			return 1;
		}
	
	}
	return -1;
}
int main(){
	vector<string> course[2501];
	int numofstu, numofcou;
	int couid,counum;
	string name;
	scanf("%d %d",&numofstu,&numofcou);
	for(int i=0;i<numofcou;i++){
		scanf("%d %d",&couid,&counum);
		while(counum--){
			cin>>name;
			course[couid].push_back(name);
		}
		sort(course[couid].begin(),course[couid].end());
	}
	vector<int> res;
	while(numofstu--){
		cin>>name;
		res.clear();
		for(int j=1;j<=numofcou;j++){
			if(findName(course[j],name)==1){
				res.push_back(j);
			}
		}
		cout<<name<<" "<<res.size();
		for(int a=0;a<res.size();a++){
			cout<<" "<<res[a];
		}
		cout<<endl;
		
	}
return 0;
}

想法是好的,但是又是超时了这次,且效率没有明显提升,查找省出来的时间用到了sort()上

PAT-A1039 Course List for Student【Map的使用】

 

 参考了一下大神的解题思路,发现我从一开始的数据录入就是有问题的才导致最后输出麻烦。他使用的是一个map来保存学生和课程之间的关联.map<string,vector<int>>;键是学生的姓名,值是学生的课程。这样那个学生要成绩列表直接以学生姓名为键的值就好了

#include <cstdio>
#include <map>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
int main() {
    // 读取输入
    int N, K;
    scanf("%d %d", &N, &K);
    map<string, vector<int>> data;
    string name;
    for(int i = 0,j, L; i < K; i++){
        scanf("%d %d", &j, &L);
        for(int k = 0; k < L; k++){
            cin >> name;
            data[name].push_back(j);
        }
    }
    
    // 遍历输出结果
    vector<int> v;
    for(int i = 0; i < N; i++){
        cin >> name;
        v = data[name];
        // 输出每个学生的课程序号之前要排序
        sort(v.begin(), v.end());
        // 输出学生名称和课程总数
        printf("%s %ld", name.c_str(), v.size());
        // 输出课程序号
        int s=v.size();
        for(int a =0; a<s; a++){
            printf(" %d", v[a]);
        }
        putchar('\n');
    }
    return 0;
}

PAT-A1039 Course List for Student【Map的使用】

Tips:由于for循环是每执行一次都要计算一下边界,因此最好提前把边界计算出来作为一个定值来做循环,这样可以在一定程度上减少实行时间。这也就是为什么vector的迭代器遍历要慢