欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ 1979 Red And Black 红与黑DFS深搜 AC代码C++

程序员文章站 2022-07-12 21:50:54
...

Red and Black

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 53332 Accepted: 28261

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

AC代码:

#include<iostream>
using namespace std;
const int MAX_WH=20;
char m[MAX_WH+1][MAX_WH+1];
int w=1,h=1,sx,sy,ans=0,count=0,res[1000],mx[4]={-1,0,1,0},my[4]={0,-1,0,1};
int main()
{
 void solve();
 while(!(w==0&&h==0))
 {
  ans=0;
  cin>>w>>h;
  if(w==0&&h==0)  break;
  for(int i=0;i<h;i++)
   for(int j=0;j<w;j++)
    cin>>m[i][j];
  solve();
  count++;
 }
 for(int i=0;i<count;i++)
  cout<<res[i]<<endl;
 return 0;
}
void solve()
{
 void dfs(int x,int y);
 for(int i=0;i<h;i++)
  for(int j=0;j<w;j++)
   if(m[i][j]=='@')
    dfs(i,j);
 res[count]=ans;
}
void dfs(int x,int y)
{
 ans++;
 m[x][y]='#';
 for(int i=0;i<4;i++)
 {
  int nx=x+mx[i],ny=y+my[i];
  if(nx>=0&&nx<h&&ny>=0&&ny<w&&m[nx][ny]=='.')
   dfs(nx,ny);
 }
}

注意:

①输入w h对应 列 和 行
②题目要求连续输入 所以我用数组保存各个结果 count用来计数
POJ 1979 Red And Black 红与黑DFS深搜 AC代码C++