HDU 4750 Count The Pairs(最小生成树)
Count The Pairs
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1627 Accepted Submission(s): 712
Problem Description
With the 60th anniversary celebration of Nanjing University of Science and Technology coming soon, the university sets n tourist spots to welcome guests. Of course, Redwood forests in our university and its Orychophragmus violaceus must be recommended as top ten tourist spots, probably the best of all. Some undirected roads are made to connect pairs of tourist spots. For example, from Redwood forests (suppose it’s a) to fountain plaza (suppose it’s b), there may exist an undirected road with its length c. By the way, there is m roads totally here. Accidently, these roads’ length is an integer, and all of them are different. Some of these spots can reach directly or indirectly to some other spots. For guests, they are travelling from tourist spot s to tourist spot t, they can achieve some value f. According to the statistics calculated and recorded by us in last years, We found a strange way to calculate the value f:
From s to t, there may exist lots of different paths, guests will try every one of them. One particular path is consisted of some undirected roads. When they are travelling in this path, they will try to remember the value of longest road in this path. In the end, guests will remember too many longest roads’ value, so he cannot catch them all. But, one thing which guests will keep it in mind is that the minimal number of all these longest values. And value f is exactly the same with the minimal number.
Tom200 will recommend pairs (s, t) (start spot, end spot points pair) to guests. P guests will come to visit our university, and every one of them has a requirement for value f, satisfying f>=t. Tom200 needs your help. For each requirement, how many pairs (s, t) you can offer?
Input
Multiple cases, end with EOF.
First line:n m
n tourist spots ( 1<n<=10000), spots’ index starts from 0.
m undirected roads ( 1<m<=500000).
Next m lines, 3 integers, a b c
From tourist spot a to tourist spot b, its length is c. 0<a, b<n, c(0<c<1000000000), all c are different.
Next one line, 1 integer, p (0<p<=100000)
It means p guests coming.
Next p line, each line one integer, t(0<=t)
The value t you need to consider to satisfy f>=t.
Output
For each guest's requirement value t, output the number of pairs satisfying f>=t.
Notice, (1,2), (2,1) are different pairs.
Sample Input
2 1 0 1 2 3 1 2 3 3 3 0 1 2 0 2 4 1 2 5 5 0 2 3 4 5
Sample Output
2 2 0 6 6 4 4 0
Source
2013 ACM/ICPC Asia Regional Nanjing Online
利用kruskral找最小生成树的瓶颈边,
#include <bits/stdc++.h>
using namespace std;
const int MAXN = 100005;
const int MAXM = 500005;
const int INF = 0x3f3f3f3f;
typedef long long ll;
struct node
{
int u,v,w;
}edge[MAXM];
int pre[MAXN],val[MAXN];
int sum[MAXN];
ll ans[MAXN];
bool cmp(struct node a,struct node b)
{
return a.w < b.w;
}
int Find(int x)
{
if(pre[x] == x) return pre[x];
else return pre[x] = Find(pre[x]);
}
int main(void)
{
int n,m;
while(scanf("%d %d",&n,&m) != EOF) {
for(int i = 0; i < m; i++) {
scanf("%d %d %d",&edge[i].u,&edge[i].v,&edge[i].w);
}
for(int i = 0; i <= n; i++) {
pre[i] = i;
sum[i] = 1;
ans[i] = 0;
}
sort(edge,edge + m,cmp);
int cnt = 0;
int fx,fy;
for(int i = 0; i < m; i++) {
fx = Find(edge[i].u);
fy = Find(edge[i].v);
if(fx != fy) {
ans[cnt] = (ll)sum[fx] * (ll)sum[fy];
val[cnt] = edge[i].w;
cnt++;
pre[fx] = fy;
sum[fy] += sum[fx];
}
}
for(int i = 1; i < cnt; i++) {
ans[i] += ans[i - 1];
}
int q;
scanf("%d",&q);
ll t;
while(q--) {
scanf("%lld",&t);
if(t > val[cnt - 1]) {
printf("0\n");
continue;
}
int pos = lower_bound(val,val + cnt,t) - val;
printf("%lld\n",(ans[cnt - 1] - ans[pos - 1]) * 2);
}
}
return 0;
}
上一篇: PHP编程的文件资源管理一例
下一篇: PHP如何递归保存到一个数组里面