欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU 5540 Secrete Master Plan

程序员文章站 2022-06-08 14:09:27
...

Secrete Master Plan

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1281    Accepted Submission(s): 762


Problem Description
Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form 2×2 matrix, but Fei didn't know the correct direction to hold the sheet. What a pity!

Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.
HDU 5540 Secrete Master Plan
 

Input
The first line of the input gives the number of test cases, T(1T104)T test cases follow. Each test case contains 4 lines. Each line contains two integers ai0 and ai1 (1ai0,ai1100). The first two lines stands for the original plan, the 3rd and 4th line stands for the plan Fei opened.
 

Output
For each test case, output one line containing "Case #x: y", where x is the test case number
(starting from 1) and y is either "POSSIBLE" or "IMPOSSIBLE" (quotes for clarity).
 

Sample Input

4 1 2 3 4 1 2 3 4 1 2 3 4 3 1 4 2 1 2 3 4 3 2 4 1 1 2 3 4 4 3 2 1
 

Sample Output

Case #1: POSSIBLE Case #2: POSSIBLE Case #3: IMPOSSIBLE Case #4: POSSIBLE
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  6079 6078 6077 6076 6075 
 


网上说是水题,但是我对这种题一直有毒,3遍才交上,一切尽在代码中

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

int t,a[5],b[5];
int cas=0,tmp;

int check(){
	for(int i=0;i<4;i++){
		int j;
		for(j=0;j<4;j++){
			if(a[(i+j)%4]!=b[j])
				break ;
		}
		if(j==4)
			return 1;
	}
	
	return 0;
}

int main(){
	
	scanf("%d",&t);
	while(t--){
		for(int i=0;i<4;i++){
			scanf("%d",a+i);
		}
		tmp=a[2];
		a[2]=a[3];
		a[3]=tmp;
		
		for(int i=0;i<4;i++){
			scanf("%d",b+i);
		}
		tmp=b[2];
		b[2]=b[3];
		b[3]=tmp;
		int flag=check();
		printf("Case #%d: ",++cas);
		if(flag){
			printf("POSSIBLE\n");
		}	
		else{
			printf("IMPOSSIBLE\n");
		}
	}
	
	
	return 0;
}