欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页  >  后端开发

请做过工商银行B2C开发的人来帮帮忙

程序员文章站 2024-04-06 17:42:37
...
php 用工行给的demo做测试,但是总是报错:
Warning: dl() [function.dl]: Not supported in multithreaded Web servers - use extension=php_infosec.dll in your php.ini
然后我在php.ini里面加了“extension=php_infosec.dll”,把工行提供的php_infosec.dll文件放到扩展目录下,重启apache,还是报这个错
我通过phpinfo查找,发现infosec这个模块一直没有加载上,请问是什么原因?

回复讨论(解决方案)

路径或者参数不对。参考这个
http://blog.163.com/caijunwei245@126/blog/static/645034342008012101045629/

是用的wamp吗

给你的是 php_infosec.dll ?
如果是 php 扩展,那么请询问一下:是与 php 哪个版本配套的

看看logs/error_log。扩展对应的php版本不一致也有可能

请问楼主解决了吗?解决了能否分享下?

用工行给的demo做测试,但是总是报错:
Warning: dl() [function.dl]: Not supported in multithreaded Web servers - use extension=php_infosec.dll in your php.ini
然后我在php.ini里面加了“extension=php_infosec.dll”,把工行提供的php_infosec.dll文件放到扩展目录下,重启apache,还是报这个错
我通过phpinfo查找,发现infosec这个模块一直没有加载上,请问是什么原因?
楼主,我也遇到了这个问题 你现在解决了吗?

我也遇到了哇,怎么解决呢,求答复

我也遇到了哇,怎么解决呢,求答复
这个我没有在windows下配置成功,后来我放弃了,直接在linux下配成功了
这个与你的php版本有关系,工行那边人说 php版本是第三方公司开发的,所以版本只能找第三方公司要,你多和他们沟通就好了


用工行给的demo做测试,但是总是报错:
Warning: dl() [function.dl]: Not supported in multithreaded Web servers - use extension=php_infosec.dll in your php.ini
然后我在php.ini里面加了“extension=php_infosec.dll”,把工行提供的php_infosec.dll文件放到扩展目录下,重启apache,还是报这个错
我通过phpinfo查找,发现infosec这个模块一直没有加载上,请问是什么原因?
楼主,我也遇到了这个问题 你现在解决了吗?
这个我没有在windows下配置成功,后来我放弃了,直接在linux下配成功了
这个与你的php版本有关系,工行那边人说 php版本是第三方公司开发的,所以版本只能找第三方公司要,你多和他们沟通就好了