欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页  >  IT编程

poj-3253 fence repair(贪心题)

程序员文章站 2023-01-13 15:29:20
题目描述: Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) pla ......

 

题目描述:

farmer john wants to repair a small length of the fence around the pasture. he measures the fence and finds that he needs n (1 ≤ n ≤ 20,000) planks of wood, each having some integer length li (1 ≤ li ≤ 50,000) units. he then purchases a single long board just long enough to saw into the n planks (i.e., whose length is the sum of the lengths li). fj is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

fj sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to farmer don's farm with this long board and politely asks if he may borrow a saw.

farmer don, a closet capitalist, doesn't lend fj a saw but instead offers to charge farmer john for each of the n-1 cuts in the plank. the charge to cut a piece of wood is exactly equal to its length. cutting a plank of length 21 costs 21 cents.

farmer don then lets farmer john decide the order and locations to cut the plank. help farmer john determine the minimum amount of money he can spend to create the n planks. fj knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

input

line 1: one integer n, the number of planks 
lines 2.. n+1: each line contains a single integer describing the length of a needed plank

output

line 1: one integer: the minimum amount of money he must spend to make n-1 cuts
 
sample input
3
8
5
8
sample output
34
hint
he wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
the original board measures 8+5+8=21. the first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. the second cut will cost 13, and should be used to cut the 13 into 8 and 5. this would cost 21+13=34. if the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
 
题目大意:两根木棒拼在一起花费的费用是两根木棒的长度和,问最小的费用使得所有的木棒拼为一根
思路:每次都找最短的两条合并起来,然后直至拼成只有一条,比较菜的用了优先队列
 
 ac代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<set>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define eps 1e-10
typedef long long int ll;
const int maxn=2e4+5;
const int mod=1e9+7;

int main()
{
    priority_queue<int,vector<int>,greater<int> >que;
    int n,a[maxn];
    ll ans=0;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>a[i];
        que.push(a[i]);
    }
    while(que.size()>1)
    {
        int l1,l2;
        l1=que.top();
        que.pop();
        l2=que.top();
        que.pop();
        ans=ans+l1+l2;
        que.push(l1+l2);
    }
    cout<<ans<<endl;
}