欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页  >  IT编程

poj-1651 multiplication puzzle(区间dp)

程序员文章站 2023-01-13 13:48:08
Time limit1000 ms Memory limit65536 kB The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the ......

time limit1000 ms

memory limit65536 kb

 

the multiplication puzzle is played with a row of cards, each containing a single positive integer. during the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. it is not allowed to take out the first and the last card in the row. after the final move, only two cards are left in the row. 

the goal is to take cards in such order as to minimize the total number of scored points. 

for example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

if he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

input

the first line of the input contains the number of cards n (3 <= n <= 100). the second line contains n integers in the range from 1 to 100, separated by spaces.

output

output must contain a single integer - the minimal score.

sample input

6
10 1 50 50 20 5

sample output

3650
题意:头尾不动,每次都取一个数,使得它和它的两边的数相乘为去掉这个数的价值,问直到只剩下头尾所需的最小价值
题解:求出每个区间的最小值,直到扩充到整个区间,区间dp
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<stack>
using namespace std;
#define pi 3.14159265358979323846264338327950
#define inf 0x3f3f3f3f;

int n,i,j,k,l;
int dp[110][110];
int a[1010];
void solve()
{
    for(l=2;l<=n;l++)
    {
        for(i=2;i+l<=n+1;i++)
        {
            j=i+l-1;
            dp[i][j]=inf;
            for(k=i;k<j;k++)
                dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i-1]*a[k]*a[j]);
        }
    }
    printf("%d\n",dp[2][n]);
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
       for(int i=1;i<=n;i++)
          cin>>a[i];
      solve();
    }
}