关于android "Compatibility兼容包"里的sample "Support4Demos"无法编译通过

最近想看看谷歌的兼容包到提供了哪些功能,

打开Eclipse,新建一个项目,把Compatibility 里的Support4Demos 项目导入进来

选用android1.6的sdk,结果死活都无法编译通过,

网上之前看到的说是兼容1.6及以上的sdk版本,

鼓捣了一天半怎么也弄不成功,

后来直接使用android4.0版本sdk,可以编译通过,

于是怎么也想不明白如果要使用这么高版本的sdk那这个兼容包有什么用呢?

后来才弄明白,这个兼容包对不同级别的sdk版本有不同的兼容效果,

要编译通过必须选择比较高的sdk版本,然后最小sdk选择低点的,

编译通过后也能进行安装,在2.1里能使用挺多功能的,这个就大家自己去试了。

然而还有个问题没解决,1.6版本完全没办法运行这个sample...

知道的朋友跟我说一下谢谢了~

猜你喜欢