欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Power Strings (循环节问题)

程序员文章站 2022-07-15 10:44:14
...

POJ - 2406 

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 1e6+7;
char str[MAXN];
int nxt[MAXN];
void getnxt(int m){
//	int i=0,j=-1;
//	nxt[0]=-1;
//	while(i<m){
//		if(j==-1||str[i]==str[j]){
//			i++;
//			j++;
//			nxt[i]=j;
//		}
//		else j=nxt[j];
//	}
	int i=1,j=0;
	nxt[0]=0;
	while(i<m){
		if(str[i]==str[j]) nxt[i++]=++j;
		else if(!j) {
			nxt[i]=0;
			i++;
		}
		else j=nxt[j-1];
	}
}
int main(){
	while(~scanf("%s",str) && str[0]!='.'){
		int len=strlen(str);
		getnxt(len);
		int l=len-nxt[len-1];   //l为最小循环节 
		//printf("%d\n",nxt[len]); 
		if(len%l==0) printf("%d\n",len/l);
		else printf("1\n");
	}
	return 0;
}