欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

PAT A1099:Build A Binary Search Tree之中序遍历建树

程序员文章站 2022-07-13 08:36:20
...

题目描述

1099 Build A Binary Search Tree (30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.Both the left and right subtrees must also be binary search trees.Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

PAT A1099:Build A Binary Search Tree之中序遍历建树

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree.
The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

求解思路

首先对输入序列进行预处理排序(升序),利用中序遍历建立一棵二叉搜索树,然后再根据层次遍历序列输出二叉搜索树。

代码实现(AC)

#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;
struct Node{
	int data;
	int lchild;
	int rchild;
}node[110];
int d[110];
int n;
int index=0;
void inorder(int root)
{
	if(root==-1)	return;
	inorder(node[root].lchild);
	node[root].data=d[index++];
	inorder(node[root].rchild);
}
void levelorder()
{
	queue<int>q;
	q.push(0);
	int cnt=0;
	while(!q.empty())
	{
		int t=q.front();
		q.pop();
		if(++cnt!=n)	printf("%d ",node[t].data);
		else printf("%d",node[t].data);
		if(node[t].lchild!=-1)	q.push(node[t].lchild);
		if(node[t].rchild!=-1)	q.push(node[t].rchild);
	}
}
void solve()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d %d",&node[i].lchild,&node[i].rchild);	
	} 
	for(int i=0;i<n;i++)
	{
		scanf("%d",&d[i]);
	}
	sort(d,d+n);
	inorder(0);
	levelorder();
}
int main()
{
	solve();
	return 0;
}