欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

DFS(深度优先搜索)---城堡问题

程序员文章站 2022-07-07 22:53:04
...

题目描述:

DFS(深度优先搜索)---城堡问题DFS(深度优先搜索)---城堡问题

上图是一个城堡的地形图。请你编写一个程序,计算城堡一共有多少房间?最大的房间有多大?城堡被分割成 m×n(m≤50,n≤50) 个方块,每个方块可以有0~4面墙

DFS(深度优先搜索)---城堡问题

Sample Input

4 
7 
11 6 11 6 3 10 6 
7 9 6 13 5 15 5 
1 10 12 7 13 7 5 
13 11 10 8 10 12 13 

Sample Output

5
9

代码:

#include<iostream>
#include<cstring>
using namespace std;
int maze[60][60],M,N;
int book[60][60]; //用于标记遍历过的房间
int roomnum=0,maxroom=0,room;//记录房间数、最大房间、目前房间大小; 
void dfs(int x,int y)
{
	
	if(book[x][y]) return; //若已经标记过则跳过
	
	room++;
	
	book[x][y]=1;
	
	if((maze[x][y]&1)==0) dfs(x,y-1);
 
	if((maze[x][y]&2)==0) dfs(x-1,y);
 
	if((maze[x][y]&4)==0) dfs(x,y+1);
 
	if((maze[x][y]&8)==0) dfs(x+1,y);
}
int main()
{
	cin>>M>>N;
	for(int i=0;i<M;i++) for(int j=0;j<N;j++) cin>>maze[i][j];
	for(int i=0;i<M;i++) for(int j=0;j<N;j++)
	{
		if(!book[i][j]) 
		{
			room=0;
			roomnum++;//更新房间数 
			dfs(i,j);
			maxroom=maxroom>room?maxroom:room;//更新最大房间 
		}
	} 
	cout<<roomnum<<endl<<maxroom<<endl;
	return 0;
} 

注意:

此题的代码有两个数组,一个是用来遍历,一个是用来标记,若只设置一个数组就非常麻烦(这里就不说为什么麻烦了,毕竟只设置一个数组我当时花了好久也没弄出来)

补充:

(!1 == !2 == 无限 0 )
相关标签: mooc 简易算法