欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1122 Hamiltonian Cycle(25 分)

程序员文章站 2022-03-08 16:44:10
...

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

思路:

满足以下条件之一或几个就不是哈密顿环:

  1. n不等于N+1;
  2. 相邻两个结点不相连;
  3. 头尾两个结点不一样;
  4. 环没有覆盖所有结点。

C++:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int MAX = 210;
int n , m , q;
int mp[MAX][MAX]={0};
int visited[MAX];
vector<int> path;
int main(){
	cin>>n;
	cin>>m;
	for(int i=0;i<m;i++){
		int a , b;
		scanf("%d%d",&a,&b);
		mp[a][b]=mp[b][a]=1;
	}
	cin>>q;
	for(int j=0;j<q;j++){
		int flag=1;
		fill(visited,visited+MAX,0);
		path.clear();
		int num;
		scanf("%d",&num);
		for(int i=0;i<num;i++){
			int tempv;
			scanf("%d",&tempv);
			path.push_back(tempv);
		}
		if(*path.begin()!=*(path.end()-1)||num-1!=n) flag=0;
		else{
			for(int i=0;i<num-1;i++){
				if(visited[path[i]]==0&&mp[path[i]][path[i+1]]==1){
					visited[path[i]]=1;
				}
				else{
					flag=0;break;
				}
			}
		}
		if(flag==0){
			printf("NO\n");
		}
		else{
			printf("YES\n");
		}
	}
	return 0;
}